#12823 Access to control unit.

Closed Created by @whistlewood - 8 comments

From @whistlewood 06.11.2017, 20:05
The problem I am having is getting my Carrera Digital control unit to find the app. My iPad finds the control unit and connects it to Bluetooth. When I open the Smart Race app or the Carrera app the app says scanning or searching for control unit but never finds it. Any ideas what I am doing wrong? I am running IOS 11.
#1 From @smartrace 06.11.2017, 20:22 Owner
Hi Jeff,

well, there are issues on iOS 11 for some users (caused by things changed by apple, not SmartRaces fault). But just to be sure: can you please read this and let me know if it helped? https://www.smartrace.de/en/manual/trouble-shooting/no-connection/ (especially the last red box).

Thanks!

Marc
#2 From @whistlewood 06.11.2017, 21:30
Unfortunately this does not help. The control unit is only recognized by blue tooth when the control unit is turned on. It connects but I can not remove it When the control unit is off the control unit disappears from the devices list .....known or otherwise.

I appreciate your advise.

Thanks.

Jeff
#3 From @smartrace 07.11.2017, 09:35 Owner
Hey Jeff,

so did you manually connect the CU in the first place from the bluetooth settings of your device? Is the blue LED constantly on when you start SmartRace?

Thanks!

Marc
#4 From @whistlewood 07.11.2017, 11:01
As I recall I manually connected Smart Race (and the Carrera race app) to Bluetooth each time. My process has been.....1) Turn on control unit and app connect flashes. 2) Open Settings on Ipad and open Bluetooth. Watch Bluetooth find control unit and say "connected". Blue LED light on app connect stops flashing and goes solid on. 3) Open App and wait for app to find the control unit which never happens.

I was hoping your suggestion to remove the control unit from the Bluetooth list of known devices but it is not stored as one. The control unit only shows up in the list when the control unit is turned on then it goes to "connected" with no way of removing it.

I am updating my phone from IOS 11.0.3 to 11.1 which apparently fixes bugs etc. Maybe that will help the phone. That does not explain my Ipad which is running on IOS 10.3.3

Thanks.

Jeff
#5 From @smartrace 07.11.2017, 11:22 Owner
Hi Jeff,

manually connecting device and CU can have caused the issues and must be avoided. I don't know how to remove the CU from the list of known devices on iOS 11, but on iOS 10 the CU should appear on the list of known devices as any other device (on the very bottom of the screen). Please try removing it from there.

The process should be:

- Start CU and device
- Open SmartRace
- let SmartRace find the CU on it's own and connect (no manual action needed)

Please let me know if that helps.

Marc
#6 From @whistlewood 07.11.2017, 12:54
Hi Marc.
As it turns out this issue was totally my fault. When I follow your instructions it works perfectly. Thanks so much for your help. My wife says I’m not good following instructions. I guess she’s right....again:)

One other question. When you update the app do existing users have access to the update? If so how do we access the updates?

I must say I enjoy your app very much. It’s far more user friendly than the Carrera app.

Thanks again.
Jeff
#7 From @smartrace 07.11.2017, 13:08 Owner
Hi Jeff,

glad to read its working now :-)

You are notified of any updates with the regular update procedure of the app store (there will be a little number with red background on the app store app icon on your ipad if any updates are available). You have access to all future updates. But as you might have noticed, some features are only available as in-app purchases (which may also apply to things still coming in the future). But all other things (such as bug fixes or new features which are not an in-app purchase) are always part of free updates available to all users of SmartRace.

Please let me know if you have any more questions :-)

Marc
#8 From @smartrace 13.11.2017, 10:24 Owner
Closing, please feel free to re-open anytime if you need to.

You need to be logged in to add a comment.

  • Created by

    @whistlewood
    06.11.2017, 20:05

  • Type

    Bug

  • State

    Closed

  • Priority

    normal

  • Product

    SmartRace