#13149 SmartRace app not available in Android

Closed Created by @dberg72 - 4 comments

From @dberg72 22.05.2019, 06:35
Hi Marc,

I have used and bought your app in Google Play since 2018.
That time I have installed it on my old Samsung Note 2 tablet, (android maximum 4.4.2) with great success. Great app, I like the Screen Mirroring to the big TV!

The tablet died and I have bought a new one, not a Samsung tablet this time.

The tablet is Archos 133 Oxygen, running Android 6.0.1. (2 year old model, but far newer than my old Samsung tablet).
(Other reason I have bought this tablet, is the screensize for reading comics, etc).

Yesterday I want to reinstall the SmartRace app, but I couldn't find it in Google Play.
On your website I clicked the Google Play icon and got the message in Google Play:

"Your device is not compatible with this version"

Strange as I running a higher Android version than before.

Is there any other way I can download the APK and install the latest version of your great app?
If you want to check the purchase, I have probably purchased it by my dberg72@gmail.com account.
If you need any other purchase information, please let me know.

I have read your workaround on https://www.smartrace.de/en/the-smartrace-manual/trouble-shooting/although-using-a-compatible-device-smartrace-cant-be-bought-on-google-play/
But for this I need to root my device, which I don't want.

I hope you have a work around for me.

Thanks in advance for your support.

Kind regards,

Dennis van den Berg
#1 From @smartrace 22.05.2019, 09:00 Owner
Hej Dennis,

thanks for coming here to report this. I investigated this and the issue with the Archos tablet seems to be that Google doesn't detect that it actually features Bluetooth LE (Bluetooth 4.0), although Archos themselves claim that the tablet supports it. But since Bluetooth LE is a requirement for SmartRace and Google thinks your tablet doesn't have it, it doesn't allow you to install the app. Unfortunately I can't do anything about it and I don't know if there is a way to convince Google to change this. :-(

My experience is that this problem seems to occur more often with low-cost devices. These devices seem to use low-cost bluetooth components which are not properly detected by apps utilizing them, which is why Google excludes these devices from the list of compatible devices. But I don't have evidence for this.

I'm sorry to say that there is nothing I can do about this apart from giving the advice to try another device.

Marc
#2 From @dberg72 22.05.2019, 12:47
Hi Marc,

That's not what I was expecting when I bought the tablet :-(
The reason for a low cost device is that I only want to use it for my books and SmartRace. A 13" Ipad is far too expensive, and I don't like Apple devices.... Not much other choices of this screensize (yet)

So the only problem is the Bluetooth detection?
No other way to get/download the APK file?

Dennis
#3 From @smartrace 22.05.2019, 15:41 Owner
Hey Dennis,

as far as I know, there is no other way to download the app if you don't want to root your device and use the market helper. :-(

Marc
#4 From @dberg72 22.05.2019, 18:46
Hi Marc,

Ok, thanks for replying quick. I wil look into the market helper issue or try another device as I will mirror it anyway to the TV.

Dennis

You need to be logged in to add a comment.

  • Created by

    @dberg72
    22.05.2019, 06:35

  • Type

    Bug

  • State

    Closed

  • Priority

    normal

  • Product

    SmartRace